[FIX] Wordpress High PHP-FPM usage


#21

If you have install Wordpress with fastcgi then edit this file: nano /etc/nginx/common/wpfc-php7.conf In location ~ .php$ { add this before }

#Mysettings:
fastcgi_cache_valid 200 3600s;
add_header X-Cache $upstream_cache_status;

Note: I’m using php7 that’s why my fastcgi is php7. Your might be different if its php5. But I would suggest you to use php7 because it’s faster. You can also try this with HHVM

Above configuration will store cached version once you load the page for the first time. and will be valid for 60mins or you can change the time it’s just landing page.

Note: You must not enable any other cache plugin with fcgi cache.

Read this for clarification:

Conclusion: Nginx fcgi cache is far better than plugin based cache because even if you use plugin based cache, mysql and php-fpm will still be used even with slight harmful plugins.

In my test I was having a post views count in every post. After applying above config post views were not updating. However any other js file will still load. Like: Google analytics


#22

Hi Do a Test with Purge cache and are you using memcache?


#23

Default configuration Already Store it for 60 min


#24

I am not using memcached or any other software based caching.


closed #25