Error: 'ssl-renew' is not a registered subcommand of 'site'. See 'ee help site' for available subcommands

I’m trying to renew my letsencrypt cert.

When I run:

sudo ee site ssl-renew

I get:

Error: ‘ssl-renew’ is not a registered subcommand of ‘site’. See ‘ee help site’ for available subcommands.

try to remove sudo

Without sudo, I get:

Error: Config root: /opt/easyengine is not writable by EasyEngine

try this
sudo ee site ssl-renew --force

@jounin21 this is what I get when I try your last suggestion.

Error: ‘ssl-renew’ is not a registered subcommand of ‘site’. See ‘ee help site’ for available subcommands.

what version of your easyengine try ```ee cli version
ee cli update

I almost thought your last suggestion had fixed the issue…

…but now there is an entirely different issue.

See the attached image:

Now try this Thread this is the solution

then Locate this

try to Rename your site certificate to
then sudo ee site ssl-renew

then back to this topic

Thanks @jounin21 I will give this a try. I’m not sure why these options are not showing up in search. I’m a long-time user and I go to search first, before I ask questions.

im sure you will fix that problem because im experience that last 2 weeks

This did not work! Same error as before!

go to your sftp or winscp or ftp try edit that name

Your screenshot looks like the error I am seeing except, the initial part. Mine says:

PHP Fatal error: Uncaught GuzzleHttp\Exception\ConnectException: cURL error 7: Failed to connect to port 80: Connection refused (see in phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:185

try to install the get htttp:// ACme challege on your error screen
and to fix also php of your site
try also install this

apt-get libcurl

let you trial and error

ee site disable
ee site enable

ee site reload --php

then rename the current expired certificate adress

sudo ee site ssl-renew

what im remember ive try to install something like that kind of error
andalso searching on google

and also before doing that try set your cloudflare  to Full Strict

Yes, I’m familiar with trial and error, but in the mean time, my website is down.

acme tool - newest version
libcurl - newest version

I don’t use cloudflare for anything!

I have tried this solution on two domains; both with the exact same sequence of errors.

These steps fixed one, but not the other.