Error creating site on local mac


#1

I just simply just cant understand whats wrong or what Im doing wrong.
Im trying to get EE to work on my mac. I it simple just dosent work. I cant create a site:

| OS | Darwin 18.6.0 Darwin Kernel Version 18.6.0: Thu Apr 25 23:16:27 PDT 2019; root:xnu-4903.261.4~2/RELEASE_X86_64 x86_64 |
| Shell | /bin/sh |
| PHP binary | /usr/local/Cellar/php/7.3.5/bin/php |
| PHP version | 7.3.5 |
| php.ini used | /usr/local/etc/php/7.3/php.ini |
| EE root dir | phar://ee.phar |
| EE vendor dir | phar://ee.phar/vendor |
| EE phar path | /private/var |
| EE packages dir | |
| EE global config | /Users/***/easyengine/config/config.yml |
| EE project config | |
| EE version | 4.0.14

When using --debug option I get this but I dont know how to fix it.

STDERR: Error response from daemon: OCI runtime create failed: container_linux.go:344: starting container process caused “process_linux.go:424: container init caused “rootfs_linux.go:58: mounting \”/Users/****/easyengine/services/mariadb/conf/my.cnf\” to rootfs \"/var/lib/docker/overlay2/50d0ad139a3a8e8fa3b0dcb511f21158cd985e02cd75c5315d26bb54e8cb2a5e/merged\" at \"/var/lib/docker/overlay2/50d0ad139a3a8e8fa3b0dcb511f21158cd985e02cd75c5315d26bb54e8cb2a5e/merged/etc/mysql/my.cnf\" caused \“not a directory\”"": unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type

Error: failed to start containers: services_global-db_1

And this about 20 times:

COMMAND: docker cp /var/tmp/db_exec services_global-db_1:/db_exec STDERR: Error response from daemon: not a directory
COMMAND: docker exec services_global-db_1 sh db_exec (2.292s)
STDERR: Error response from daemon: Container 1de28e025d714c19b057dc5ab5caffc0b2a31fee71930e15824132c3375316eb is not running

I have tried to kill all docker volumes. I have removed EE and installed it again. And I keep getting this error.

Does anyone know what I can do to get this to work?