-t says line of ssl_cipher has some issues (basically i had copied the above mentioned ciphers to my ssl.conf and post that nginx would not start)…

please remove the one on ssl.conf and place the ssl_cipher only on nginx.conf

Same error caused to me.

And I replace ssl_cipher with this one

ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:AES256+EECDH:AES256+EDH';

and problem resolved.


Well, Identified the issue deeply and it occurs frequently in Internet Browsers due to some uncommon reasons. I have listed down all the possible solutions and 99% your issue is going to resolve from one of the solution. Try them one by one and do reply which solution solved your issue.

Solutions Page: How to Solve Google Chrome’s Error “ERR_SPDY_PROTOCOL_ERROR"

Try clearing the cache and restart the chrome. I always do this and it works every time. take a look at some more solutions: How To Fix Chrome’s ERR_SPDY_PROTOCOL_ERROR

One of the most common problems that we face while using Google Chrome is the error " ERR_SPDY_PROTOCOL_ERROR ". You may encounter this issue while browsing certain pages on the browser.Refer the artical : ERR_SPDY_PROTOCOL_ERROR

There are many ways to fix this error, You can any one and can fix very easily, Mostly it can fix by

  1. Updating Google Chrome Browser
  2. Flush the Socket Solution
  3. Clear Cookies
  4. Restart Browser If still problem not solve then try manually for more fixes.

Perhaps try to change your current SSL Cipher with these:

I had one of my sites suddenly go down with a SPDY_PROTOCOL_ERROR, all my other sites were operational so I knew 100% it was nothing to do with any certificate problem.

I eventually traced it to a permissions problem with the location for the nginx fastcgi cache. A simple chown -R www-data:www-data on the /var/cache/nginx folder resolved it for me immediately. Hopefully this may help someone in future.

Hi, Mahendra meghwal Your suggestion really working for me. I find that mostly it is happen due to cookies and also Antivirus. I found also a good site where you can find right fixes. Thanks

This is also happen due to Anti Virus, If you are using Avast Safe sure it will due to this. You can try it via disable.

I am facing this error many times. i jusy found some simple solution to resloved this error here. few normal steps write about here

100% working try this fix

HTTP/2 has a huge blacklist of old and insecure ciphers, so we must avoid them. Try the following configuration, it works for me (EasyEngine v3.8.1 / Ubuntu 18.04 LTS)


Working reference:

Thank You

Worked perfectly. Thanks!

this worked for me!

I see everyone posting fixes on how to resolve this issue but why hasn’t the ee script been updated to resolve this issue. I have created 5 new sites recently and each of them has the same issue. It requires me to go in and follow this guide.

How to fix ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY in both chrome and firefox. I am a beginner can you please explain me in detailed steps. thanks in advance.

Anyone there? Can you please help me how to fix ERR_SPDY_INADEQUATE_TRANSPORT_SECURITY in both chrome and firefox. My site is opening in internet explorer and safari browser but not opening in chrome and firefox browser. I am a beginner can you please explain me in detailed steps. thanks in advance.